mirror of
https://github.com/Defelo/nginx-oidc.git
synced 2025-05-12 13:02:48 +00:00
49 lines
879 B
Nix
49 lines
879 B
Nix
{ lib, pkgs, ... }:
|
|
|
|
{
|
|
tree-root-file = ".git/config";
|
|
on-unmatched = "warn";
|
|
|
|
excludes = [
|
|
"*.lock"
|
|
"*.md"
|
|
".envrc"
|
|
".gitattributes"
|
|
".gitignore"
|
|
"Cargo.nix"
|
|
];
|
|
|
|
formatter.nixfmt = {
|
|
command = lib.getExe pkgs.nixfmt-rfc-style;
|
|
includes = [ "*.nix" ];
|
|
options = [ "--strict" ];
|
|
};
|
|
|
|
formatter.prettier = {
|
|
command = lib.getExe pkgs.nodePackages.prettier;
|
|
includes = [
|
|
"*.json"
|
|
"*.yml"
|
|
];
|
|
options = [ "--write" ];
|
|
};
|
|
|
|
formatter.rustfmt = {
|
|
command = lib.getExe pkgs.rustfmt;
|
|
includes = [ "*.rs" ];
|
|
options = [
|
|
"--config=skip_children=true"
|
|
"--edition=2024"
|
|
];
|
|
};
|
|
|
|
formatter.taplo = {
|
|
command = lib.getExe pkgs.taplo;
|
|
includes = [ "*.toml" ];
|
|
options = [
|
|
"format"
|
|
"--option=column_width=120"
|
|
"--option=align_comments=false"
|
|
];
|
|
};
|
|
}
|