18 lines
279 B
Nix
18 lines
279 B
Nix
{ lib, pkgs, ... }:
|
|
|
|
{
|
|
tree-root-file = ".git/config";
|
|
on-unmatched = "error";
|
|
|
|
excludes = [
|
|
"*.lock"
|
|
"*.md"
|
|
"LICENSE"
|
|
];
|
|
|
|
formatter.nixfmt = {
|
|
command = lib.getExe pkgs.nixfmt-rfc-style;
|
|
includes = [ "*.nix" ];
|
|
options = [ "--strict" ];
|
|
};
|
|
}
|